SELECT - Incorrect Account Connection Error Emails – Incident details

Incorrect Account Connection Error Emails

Resolved
Operational
Started 3 months agoLasted about 5 hours

Affected

App Frontend (select.dev/app)

Operational from 6:37 AM to 11:40 AM

Updates
  • Resolved
    Resolved

    The issue with our emailing service has been identified and resolved. We will be conducting a post mortem today and contacting customers who received multiple emails.

  • Investigating
    Investigating

    SELECT rolled out a new notification system for account connection errors which has resulted in a significant number of emails being sent out.